This Porta-generated SimpleViewer album requires Adobe Flash ver. 7 (or newer).
If you already have Flash installed, view the Flash-based album. Otherwise, view the HTML-based album.